In order to prevent the reverse engineering of script applications, many developers encrypt their program code with tools such as ionCube PHP Encoder to make it human unreadable. The aforementioned is valid for paid applications in particular, because anybody could possibly use and change the unencrypted code without having to pay the necessary license fees. When you buy web software protected with ionCube PHP Encoder, you can use it without a problem as long as an instrument named ionCube Loader is present on the hosting server. This loader allows you to execute encrypted files and you will often see it as one of the prerequisites for a given script app to be set up. Since the encoded files are already precompiled, they're normally executed much faster and this will enhance the general speed of your site.

IonCube in Cloud Web Hosting

When you purchase a Linux cloud web hosting package from us, it'll be created on our in-house made cloud platform where ionCube Loader is already installed, so you will not have any kind of problems to manage any script application that needs the instrument to function appropriately. In addition, we offer you a few different versions of PHP, therefore if you switch the version, you'll need to enable ionCube again. Our platform remembers the adjustments you make, so in case you go back to the previous version of PHP that was active for your account, ionCube Loader will already be enabled. The PHP version and the ionCube tool can be managed through the PHP Configuration part of our Hepsia website hosting Control Panel. Any adjustment that you make takes literally just a mouse-click and it will take effect immediately.

IonCube in Semi-dedicated Hosting

If you aquire a semi-dedicated server package from our company, you can employ any script-driven app that needs ionCube Loader since the tool is available on all servers that are a part of our revolutionary cloud website hosting platform. In addition, we support various releases of PHP, which means that if you move from PHP 4 to 5.2 or 5.3, for example, you can activate ionCube for this particular version with just a click from your Hepsia Control Panel. Our system will remember your choice, and in case you move back to the previous version of PHP, the instrument will already be active. For more tech-savvy users, we also offer the option to choose the PHP version and whether ionCube will be active or not for a particular domain name without altering the settings for the entire hosting account. This is done by placing a php.ini file within a domain folder with a few lines of code.